WordPress.org

Brasil

Ready to get started?Download WordPress

Fórum Brasileiro

[resolvido] Erro de Acento (9 posts)

  1. arilsonjunior
    Membro
    Publicado 3 anos atrás #

    Olá,

    Estou com um sério problema de acentuação em 2 temas do wordpress. Os temas estão hospedados em banco de dados e servidores diferentes, porém o erro é o mesmo nos 2 casos.
    A letra que possuem acento simplesmente não aparece, a configuração de leitura já esta em UTF-8 (já testei a ISO também) o erro acontece somente nos títulos (widgets e posts).
    Já tentei implementar a correção:

    (<?php header(“Content-Type: text/html; charset=ISO-8859-1“,true)

    e

    (<?php header(“Content-Type: text/html; charset=UTF-8“,true)

    Mas nada, como disse os erros só aparecem nos títulos.

  2. Myst1010
    Membro
    Publicado 3 anos atrás #

    Provavelmente seu tema usa o plugin jquery cuffon para poder usar fontes diferentes das normais usadas na net, mas o autor do tema usou uma fonte não latina que não tem acentos, então o plugin não coloca nada no lugar desta letra acentuada.

    Se for este mesmo o caso vc deve usar outra fonte que tenha acentos e trocar por esta que está sendo usado.

    Aqui tem um tutorial de como trabalhar com o cufon
    http://www.verticis.com.br/blog/tutoriais/como-utilizar-qualquer-fonte-em-sua-pagina-com-cufon/

    Uma busca no google sobre cufon vai ter vários tutoriais sobre e claro a página que vc poderá fazer a conversão de qualquer fonte que deseja usar no lugar desta que está sendo usada.

  3. arilsonjunior
    Membro
    Publicado 3 anos atrás #

    Ta Ok Myst1010!
    Vou testar o recurso do Cufon.

    Obrigado!

  4. arilsonjunior
    Membro
    Publicado 3 anos atrás #

    Sem Sucesso !! =/
    Tentei os passos do link e um plugin no wordpress mas não resolveu.

  5. Myst1010
    Membro
    Publicado 3 anos atrás #

    tem um link para olharmos o problema?

  6. arilsonjunior
    Membro
    Publicado 3 anos atrás #

  7. Myst1010
    Membro
    Publicado 3 anos atrás #

    Está dando erro na página onde o link está tentando abrir.

    Mas mesmo com o erro eu pude ver que vc está usando o tema magzimus e ele usa sim o cufon.

    Aqui um tutorial mais detalhado de como gerar a fonte com os acentos, se é que a fonte usada tem acentos é claro.
    http://www.webmaster.pt/usar-font-nao-suportada-sem-imagens-6567.html

    Neste tutorial está falando de outras técnicas de usar fontes diferente, atente somente a parte do cufon para proceder com a troca de sua fonte.

    Se tiver dificuldade e como seu tema é pago entre em contato com o autor do tema para obter suporte.

  8. arilsonjunior
    Membro
    Publicado 3 anos atrás #

    Valeu Myst1010, é o link está com erro.
    Vou dar uma olhada no tutorial. o/

  9. arilsonjunior
    Membro
    Publicado 3 anos atrás #

    Cara, consegui achar as fontes e substitui-las.
    Valeu pelas dicas, muitos temas usam o Cufon.
    Flw!

Tópico Encerrado

Este tópico foi encerrado para novas respostas.

About this Topic